Zend Framework, Zend_DB und ? in dem SQL

Kommentieren Dec 23 2008

 

Sollte irgend jemand schon mal den Fehler bekommen haben:

Invalid parameter number: no parameters were bound" when using ' and ? in where clause


dem kann geholfen werden.

Dazu ist aber folgendes nötig. Man braucht mindestens MySQL 4.1.3 sowie die mysqli extension von PHP. Denn damit sollte der Fehler nicht mehr kommen.

Hat mich schon ne weile genervt, da ich einfach nicht dahinter gekommen bin warum.

Hier ist sogar ein Bug dazu:
Invalid parameter number: no parameters were bound” when using ‘ and ? in where clause

Dazu sollte man beachten, dass die mysqli Extension die bessere Wahl ist, wenn man aktuellere MySQL Datenbanken verwendet.

banana
out.